Degraded Performance
Resolved
Jul 8, 2026 at 7:00pm UTC
The system has caught up and is now working as expected.
We will continue to monitor.
Affected services
Updated
Jul 8, 2026 at 6:30pm UTC
We have identified the root and are implementing a fix now. Once deployed, the system will start to catch up.
We will monitor and update shortly.
Affected services
Updated
Jul 8, 2026 at 5:24pm UTC
The engineering team is continuing to investigate a backup in event processing.
Because of this, various functions like rating and emailing will be delayed
Affected services
Created
Jul 8, 2026 at 4:40pm UTC
Our engineering team is investigating an increased error rate while rating shipments.
Affected services