Back to overview
Degraded
System Performance Degraded
Mar 24, 2026 at 3:55pm UTC
Affected services
FreightWise TMS
Resolved
Mar 24, 2026 at 4:05pm UTC
System should now be performing as usual. We will continue to monitor.
Affected services
Updated
Mar 24, 2026 at 4:00pm UTC
We have identified the root cause and are working to resolve it.
Affected services
Created
Mar 24, 2026 at 3:55pm UTC
We are actively investigating reports of degraded system performance from our monitoring tools.
Some actions may take longer than usual to complete.
Affected services